Jump to content

FYI 03+ Truck Throttle Body Wiring Pinout


Recommended Posts

So I needed to know where the TPS wire was on my truck for the megasquirt. I hopped over to LS1 and did a search for TPS and poster BigTex. Second post I looked at had this info:

 

 

Thank you for the pictures. Thats exactly what I needed.

 

The electrical connector is physically the same as the 03+ trucks. But the trucks have 8 pins inside while the LS2 has 6 pins.

 

Doing a little research, I've got....

 

LS2 90mm

PIN ID

A.) ACT2

B.) ACT1

C.) +5v TPS Reference – Common to both TPS’s

D.) TP1 Signal 0-5v

E.) Common Ground

F.) TP2 Signal 5-0v

 

 

03 TRUCK TB

Pin - Wire Color - Function

A - YEL - TAC Motor Control 1

B - BLK/WHT - Low Reference

C - BRN - TAC Motor Control 2

D - BLK - Low Reference

E - LT BLU/BLK - 5 Volt Reference

F - PPL - TP Sensor 2 Signal

G - DK GRN - TP Sensor 1 Signal

H - GRY - 5 Volt Reference

Link to post
Share on other sites
  • 11 months later...

kind of an off the wall the question....but when i installed my BBK 80mm TB i kept getting a error code that would say "reduce engine power" or something on the dash. The truck would only have very low rpm, but if i put the stock TB back on it would be fine so i gave up on the bbk. So if i wanted to check the TPS volts and see if thats my problem, which wire would i check for the volts, E or G?? and what should the correct volts be at idle and WOT. Thanks and sorry for the off topic post

 

 

Brad

Link to post
Share on other sites
Check both TPSs.  There is a nasty code in the PCM where if TPS1 doesn't match TPS2, it slams the TB closed and disables the TB until you reset the code.

 

 

so both "f" and "g" have to match in voltage...what voltage should they be, and what if they don't match?

 

Brad

Link to post
Share on other sites

so down to brass tacks.. if you REALLY REALLY want to put a 90 mm LS2 TB on our trcusk you would need the following: 2003 Escallade TAC module, 2003 Accelerator Pedal ASM., obviously an LS-2 Throttle Body & aboot $200 worth of connectors... being that the later model TAC modules have a detection for a short between the ref. circuits.... (the only reason i say escallade is because its kinda hard to find parts/rare 03 trucks with TAC...) Thus making this swap an estimated $1,200.00 ???? :dunno: correct me if im wrong, im just a "young gun" anyhow... but i was taking some time on GM service information this morning and this is what i have concluded.... any help, any... would be greatly aprecieated

 

thanks in adv.

George

Link to post
Share on other sites
so both "f" and "g" have to match in voltage...what voltage should they be, and what if they don't match?

 

They aren't supposed to be identical voltages between sensors, but they are supposed to be very similar readings. Those sensors read the angle of the throttle blade. If the blade is at 75%, the sensors would output a certain voltage. If the blade is at 25%, the sensors would output a completely different voltage. The readings of the blade angles are compared to the reading of how far the pedal is depressed. Those readings should also be close to one another, but not necessarily identical.

 

If they don't match, the PCM detects and error and puts your truck in reduced power mode until you fix the issue and clear the code.

Link to post
Share on other sites
  • 14 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...