Jump to content
Sign in to follow this  
DatLiftedSS

Having some engine issues.

Recommended Posts

got an 03 SSS with 136000 kilometers and i keep having to add coolant every once in a while. The truck runs fine and the oil looks good apart from a little bit of sludge on the drain plug magnet on the last oil change which i believe to be unrelated, if i pull the oil cap off after driving it there's a little bit of smoke that comes out so I'm guessing what I've got on the drain plug is piston ring or bearing material but not sure, anyways that's unrelated, my main question is where could my coolant be going? i have no burnt coolant smells and the truck doesn't smoke, I see no evidence of coolant in the oil although I've read with the GM dexcool its hard to tell when it gets into the oil, and i see no evidence of a exterior leak anywhere. am i missing something here?

Share this post


Link to post
Share on other sites

You can put a cooling system pressure tester on it to see if it's got an external leak anywhere; under normal driving if it's not major it could be blowing away or evaporating before you can see it.

If you don't see an external leak anywhere.. go ahead and borrow/rent the chemical block leak test kit.  Read the instructions closely.  It'll let you know if there's combustion gases in the cooling system, i.e. head gasket failure or cracked head(s).

Richard

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...