Jump to content

Engine help...


bumgardner77
 Share

Recommended Posts

So I finally had the chance to buy an ss. its a 2004 with a lot of tlc needed. my biggest concern is that when I come to a stop there is no oil pressure but when I start driving the oil pressure comes up to about 20 psi and stays there while driving. I replaced oil sending unit sensor and oil pump but no change. I am at the point of rebuilding with all new cam and rod bearings. Does anyone have any other opinions what might be the issue?  If I rebuild does anyone recommend a good camshaft that does not need to be tuned?

Link to comment
Share on other sites

First of all, There is no such thing as a good camshaft without a tune LOL... As far as oil pressure, are you consuming a lot of oil? Does the check engine light come on or stop engine low oil pressure message appear? If so you may have a rebuild on your hand...  Otherwise check/replace the stepper motor for that gauge especially if you already replaced the pump and have no other messages or codes..

Link to comment
Share on other sites

I've done 2 oil changes since I got it. 1 when I bought it and 2nd one when I replaced oil pump. I've been told before that it could be the oring not right size and causing oil pump to suck up air? Is that possible? I bought the OEM pump and oring from a dealership

Link to comment
Share on other sites

Either put a mechanical gauge on it, or find a friend with a known good cluster to pop in. Rule out gauge error. If its really zero psi, the motor would probably rattle. I've seen the bad o-ring cause pump cavatation, but that's usually on the 07-09 trucks.

 

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 years later...
On 9/12/2019 at 1:56 PM, 2003_SuperSport said:

If its not consuming oil then maybe you got a bad pump.  Also change the oil filter just in case. You can also do a compression on all the cylinders.. Find someone to check your codes as well. 

I was wondering if you know any tuners I see ur from Minnesota and I put a big chopmonster cam and long tube headers with an upgraded tranny and need a tune any advice ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...