Jump to content
Sign in to follow this  
jmontero146

Rear end wheels shudder when making slow turns.

Recommended Posts

Cant figure out the problem.. my rear differential seems to shudder when making slow turns..had the rear differential checked and put new fluid in it and it still does the same problem..anybody ever had this issue? Maybe transfer case?

Share this post


Link to post
Share on other sites

What exact fluid went in?  Was it marked for posi-trac units?  Was posi additive used?  If so...that's the wrong stuff, and can cause incorrect lockup of the factory locker.  Eaton Gov-Loc (RPO code G80) uses just plain gear oil, no posi additive.

EDIT - lol my bad, I thought your post sounded familiar.  You had just posted about similar issues previously.

Richard

Edited by someotherguy

Share this post


Link to post
Share on other sites
58 minutes ago, someotherguy said:

What exact fluid went in?  Was it marked for posi-trac units?  Was posi additive used?  If so...that's the wrong stuff, and can cause incorrect lockup of the factory locker.  Eaton Gov-Loc (RPO code G80) uses just plain gear oil, no posi additive.

EDIT - lol my bad, I thought your post sounded familiar.  You had just posted about similar issues previously.

Richard

I drained it just incase and put the correct fluid in it just to make sure.. still does the same thing..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×