Jump to content


Photo
- - - - -

engine losing horsepower


  • Please log in to reply
4 replies to this topic

#1 sswolfpac

sswolfpac

    Veteran SS Member

  • Member
  • PipPipPip
  • 976 posts
  • Gender:Male
  • Location:massachusetts
  • Color:Victory Red
  • Year:2003

Posted 25 April 2017 - 12:07 PM

engine light on, got this message, shut off and was ok i thought, went out was driving fine then out of blue engine cut out and I was coasting at 5mph, was on a 2 lane rd wit cars almost crashing into me,  brought to mechanic and he says fuel filter , haven t got truck back yet but hope this aint one of those major issues that takes 1000s of dollars to figure out


  • 0

#2 Downeast Johnny

Downeast Johnny

    John

  • Member
  • PipPipPipPip
  • 5,051 posts
  • Gender:Male
  • Owns:SS
  • Color:Black
  • Year:2003
  • Drivetrain:AWD

Posted 25 April 2017 - 04:22 PM

Did you check for codes?  Maybe your mech did and traced it to the filter.

 

Hope it's a simple fix.


  • 0

#3 1BAD2K

1BAD2K

    US A-Hole

  • Member
  • PipPipPipPip
  • 3,417 posts
  • Gender:Male
  • Location:Texas
  • Owns:SS
  • Color:Silver Birch Metallic
  • Year:2006
  • Drivetrain:2WD

Posted 26 April 2017 - 07:23 AM

Well first thing is first. The engine light is on, so it is throwing a malfunction code. What code does it show when scanned?
  • 0
Current build: 2006 RCSB 4x4 - LS6, magnacharger, 4l80e, circle D, hydroboost, corsa, arh, beltech, coilovers, nvg149, baer+z06 upgrade, intro wheels... full on SS clone in the making.

#4 sswolfpac

sswolfpac

    Veteran SS Member

  • Member
  • PipPipPip
  • 976 posts
  • Gender:Male
  • Location:massachusetts
  • Color:Victory Red
  • Year:2003

Posted 26 April 2017 - 02:33 PM

got truck back needed new fuel filter pump and sensor, he cleaned out throttle body cuase  there was carbon build up , truck seems fine but throttle body code was thrown and pedal sensor A and B ,also  were checked and ok  hoping this was fix ,600$$


  • 0

#5 sswolfpac

sswolfpac

    Veteran SS Member

  • Member
  • PipPipPip
  • 976 posts
  • Gender:Male
  • Location:massachusetts
  • Color:Victory Red
  • Year:2003

Posted 30 April 2017 - 01:16 PM

To good to b true. Engine light back on .then went out. Getting annoying

Edited by sswolfpac, 30 April 2017 - 01:17 PM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users