Jump to content

A/C problems.....


LoneSStar
 Share

Recommended Posts

I agree with rumrunner, I'd suspect a bum compressor(especially if it was a cheaper re-man) before I'd be thinking evaporator core. You have to take the seats/console/dash/heater box out to get to the evap core, so you'd better be sure that's the problem, before you start digging.

Link to comment
Share on other sites

Yeah guys ,turned out to be a f***ed compressor!it was a reman,under warranty, so I got another one ,installed it and charged it up aND it's working great! Thanks for the replys, I do have a code for a/c recirculation actuator voltage to low? I posted about it but still unsure which one I need to replace? Thanks again

Link to comment
Share on other sites

This is the motor that controls the recirculate door. on the top pass. side of the heater box. Should be able to get at it if you pop the dash cover off, and get the dash bracing out of the way.

post-23990-0-26039100-1463598248_thumb.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...