Jump to content

Bucking in Cruise Control


fastbee
 Share

Recommended Posts

Yesterday I set my cruise control to 40 mph on a stretch of highway notorious for speed traps. I don't recall every setting it that low before. Almost immediately the truck started to buck and jerk, almost like it was coming in and out of gear. It settled down when the throttle came back in but started jerking again as soon as it came off throttle. Today I got on another long straight stretch and tried various speed settings. The truck had the same reaction at any speed above 35 mph. At 60 mph it felt and sounded like something was about to come apart. The bucking/jerking is triggered when it comes off throttle. I can push the gas pedal and it will settle down or use the cruise control controls to add speed. As long as increased fueling is being commanded it seems OK. It should be noted that there are no issues when not using cruise control, it runs fine. Anyone ever heard of or experienced this?

Link to comment
Share on other sites

cadowns - truck is tuned and has a cam and custom exhaust. Converter seems fine as it drives great as long as cruise is not being used.

EXGM - No CELs, not even any soft codes according to my scanner. Would the throttle body cause issues only in cruise?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...