Jump to content
Sign in to follow this  
Hideintire

Low idle when warm....help please!

Recommended Posts

Hi, I'm having low idle issues and would appreciate some help. 04 SS basically stock except shorty headers and true duals. Thought it was a dirty TB, but cleaned it good and no change...honestly it is worse! MAF was also cleaned, but that was about three weeks ago...before the problems started!

This problem seemed to begin after I downloaded the tune and added electric fans. Best I can tell...only the fan info changed...but the truck has run worse since and the mileage is down 1 mpg!!! Could there have been a mail-order tune on truck that EFILive did not read? It seemed to download properly...but something has changed! Any help would be greatly appreciated!!!!

Thanks,

Jimmy

Share this post


Link to post
Share on other sites

I would contact your tuner and see what he did. If it happened after the tune it's probably related. My truck idles really low too right at 500rpms.

Share this post


Link to post
Share on other sites

Efi should read the pcm no problem even with a tune. There's a couple different ways pcm can be locked, but if you downloaded it, then opened the file you should be fine. Who made the changes to your tune? You? If you want me to look at it, I'll be happy to look and see.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...