Jump to content
Sign in to follow this  
Buck_ss03

Abs and service break light turned on!!!

Recommended Posts

The past couple of days my abs and and brake light on my dash would turn on after 5min of driving. It tells me to service brakes on my service center on my dash. I thought it was my brakes so I changed them even though mine were good. It still pops up though. What could it be???

Share this post


Link to post
Share on other sites

How's your wheel bearings? The whole hub assembly has a sensor in it, and if the bearings no good or if that wire is no good it could through your abs light on,

Share this post


Link to post
Share on other sites

Best bet would be check fluid level first if that's ok then get a scan tool pull the codes see where that takes you, better off than just throwing parts at it,now your out 60$ on unneeded pads if not more than that. More than likely like Chris said its more than likely a wheel speed sensor issue

Edited by BLNAWAY

Share this post


Link to post
Share on other sites

Hi Buck_ss03,

 

I’m sorry to hear of this concern with your vehicle. I cannot guarantee anything, but I will be glad to look further into this for you. Please send us a private message referencing this thread if we can be of any extra assistance. Thank you.

 

Kristen A.

Chevrolet Customer Care

Share this post


Link to post
Share on other sites

If you need a ABS sensor i have one for each side that are like new.

Share this post


Link to post
Share on other sites

I had the same lights coming on intermittently on my c2500. Turned out to just be a bad ground under the hood

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×