Jump to content
Sign in to follow this  
tjblack03ss

Transmission problem??

Recommended Posts

So Friday night on my way home out of no where my tranny threw out of gear redlined and all 4 tires locked. Thank god I was only going 40 on a back road and didnt flip. So no the question is what could have caused this. My mods are headers, intake, corvette servo, and tune. Anybody have any ideas of what could be my problem?

Share this post


Link to post
Share on other sites
By the way it's pretty much pouring fluid out from every place possible Im trying to find out if this is a transmission problem or transfer case the truck has 97k miles on it and was well taken car of by the previous owner

Share this post


Link to post
Share on other sites

what color is the fluid?

 and if its running is it pouring fluid out?  Or can you put it in gear and will it try to move in any gear?

Share this post


Link to post
Share on other sites
Not good, sounds like a catastrophic failure of the trans to me....

Share this post


Link to post
Share on other sites

Take a peek under the truck to see where the fluid is leaking from, that will help you pinpoint whether it's the transmission or the transfer case. If either of those components locked up and punched a hole in the case, sounds like a pretty catastrophic failure. A total rebuild/replacement will be required, disassembly of the component will really be the only way to figure out what let go internally. Good luck!

Share this post


Link to post
Share on other sites
The fluid is dark pink it pours out when running in park and when I put it in gear I can feel the it shift but when I step on the gas nothing just revs in every gear reverse, drive, 3, 2, 1. And in neutral the truck won't move like the wheels are still locked even when it was put on the flat bed the tires where just dragging

Share this post


Link to post
Share on other sites
Well pinpointed the problem the shell of the transmission is shattered on the driver side just pulled a large piece of it out and there's another big piece and not sure how much is still under there

Share this post


Link to post
Share on other sites
Well the built transmission is ready I really what to know what went wrong with it when it gets taken out I will post pictures of it

Share this post


Link to post
Share on other sites
Well looks like everything inside is what broke[attachment=34970:image.jpg][attachment=34970:image.jpg]

Share this post


Link to post
Share on other sites
That looks familiar, I have some nasty photos from my last failure too...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×