Jump to content
Sign in to follow this  
dwalk

Charging system failure??

Recommended Posts

So I was driving down the road and all my internal lights went dim. I looked at my gauge and it was a little over the quarter mark.. then it dropped and all my electronics started shutting down one by one. It said CHARGING SYSTEM FAILURE and immediately after said BRAKE SYSTEM FAILURE. I pulled over freaked out that my brakes were out and the little that I used them to pull in a parking space they seemed to work. I'm actually stuck here now, waiting for my buddy to show up.. any help would be awesome as for this truck is my DD.

Share this post


Link to post
Share on other sites

Did the engine die? Sounds like you lost the alternator on your truck, aka it wasn't charging the battery and the battery went dead while you where driving. I'm sure your breaks are fine you just need to replace the alternator and charge the battery and it should be good to go. At least from the sounds of it thats what happened.

Share this post


Link to post
Share on other sites

I'm trying to take the battery out to replace it but something is holding it in place. How do I take it out?

Share this post


Link to post
Share on other sites

A small little clamp on the side with a single bolt in it. And yeah, sounds pike the alternator went. I would invest in a heavy service rebuild and a new optima yellow top.

Share this post


Link to post
Share on other sites

^^^ I agree and that bolt is a 13mm, you need a long extension to reach it usually.

Share this post


Link to post
Share on other sites

^^^ I agree and that bolt is a 13mm, you need a long extension to reach it usually.

The bolt is all the way at the bottom of the battery on the side closest to the firewall. Right in the middle of the battery.

Share this post


Link to post
Share on other sites

Replace the alternator first, not the battery!

Share this post


Link to post
Share on other sites

X2

 

x3

 

same thing happened to me when my alternator went. the computer shuts down the power brakes as it begins to lose power. Think of it has your heart stopping blood to your limbs as it tries to keep the rest alive.

Share this post


Link to post
Share on other sites

Power brakes run off of vacuum. I think your meaning the ABS

 

Sent from my DROID4 using Tapatalk 2

Share this post


Link to post
Share on other sites

It was my alternator. Went to autozone and picked up one and swapped it out. Everything is all good but I for sure gave me a scare. I feel like it runs and shifts way smoother then before... is that common?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...