Jump to content

Is It Time For A Cam Upgrade?


VeeMax
 Share

Recommended Posts

When I start my truck sometimes I here a lifter being a little lazy for a bit, it ticks for 15-20 seconds. So it sounds like it needs new lifters. If I do that I should go ahead and have a cam put in.

 

Is there a shop in the Dallas area that can do that for me? I don't think I want a dealership doing that for me.

Link to comment
Share on other sites

I will try to get a video. Its so seldom it will be difficult. Piston slap? That sounds like an engine death sentence...:eek: Although it sounds like a lifter/ rocker tick to me, but I'm far from an expert.

Link to comment
Share on other sites

I will try to get a video. Its so seldom it will be difficult. Piston slap? That sounds like an engine death sentence...:eek: Although it sounds like a lifter/ rocker tick to me, but I'm far from an expert.

 

Not really a death sentence, it is just a bit annoying that's all.........get a video if you can.....

Link to comment
Share on other sites

That said, I know the NBS GM trucks (with AFM) have a problem with failing lifters.

 

But a V-Max doesn't have that feature, correct??

I do believe mine has the afm. Switching to V4?

Link to comment
Share on other sites

I do believe mine has the afm. Switching to V4?

 

 

Yes, it should show "V4" up on the dash when u are coasting downhill, or along a flat stretch of road.

 

If so, throw in a fresh new set of new lifters and an oil change with a good oil filter....

 

:thumbsup:

Edited by Bad Bowtie
Link to comment
Share on other sites

  • 1 month later...

Update, I changed the oil to Mobil One and Mobil One filter and the seemingly lifter ticks at startup went away. Just thought I would share that.:pepsicheer:

 

That's great news, i would blame the oil filter for that, what filter brand did you use before the Mobil 1?

Link to comment
Share on other sites

  • 2 months later...

That's great news, i would blame the oil filter for that, what filter brand did you use before the Mobil 1?

 

I'm not sure what filter was on there, I had just purchased the truck( I had it just a few months). The filter may have restricted the oil a little too much huh? Well so far is has been fine and on the 2nd oil change of the Mobil One. Going to put the 6.0 to the test tomorrow. Hauling the atv's to the Cali sand dunes from Dallas, about a 3000 mile round trip.

:pepsicheer:

 

IMG_20111106_131523.jpg

Edited by VeeMax
Link to comment
Share on other sites

  • 2 weeks later...

You should probably still get a new cam! :peelout:

Ha, you got that right! Don't think it hasnt crossed my mind... :pepsicheer: Its already a tire smoker... I had to sell my Camaro because I kept getting in trouble.. :driving:

Edited by VeeMax
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...