Jump to content

Search the Community

Showing results for tags 'Electric fans'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Lifestyle & Hobbies
    • Off-Topic/General
    • The Automotive Industry
    • Member Introductions
    • Video & Photography
    • Firearms & Hunting
    • Sports & The Outdoors
    • MiSSed Connections & SSpotted
    • My New Truck
    • Events, Gatherings, & Rallys
    • Comment Box
  • Truck of the Month
    • Truck of the Month
  • Technical
    • General SS
    • How To
    • Builds
    • AWD, Differential, & Transmission Tech
    • Suspension & Brakes
    • Radio/Electronics/Security
    • For Sale/ Wanted
    • Rims and Rubber
  • Engine Technical
    • Engine Tech And Modification
    • PCM Tuning
    • Bolt On Performance
    • Forced Induction and Nitrous
  • Non Silverado SS
    • VHO/V-Max General
  • Street & Strip
    • Street
    • Strip
    • Appearance, Cleaning, & Detailing
  • Preferred Vendors
    • Vendor/Member Praise/Complaints
    • GMPartsDirect.com
    • Black Bear Performance

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Name


Location


Interests


Build Date/TPW


Delivering Dealership


Delivery Date


Modifications

Found 2 results

  1. Guys, my 2004 SSS just started to give me some problems. First, I don't daily her anymore and she stays in my garage during the week. After not turning her on for about 2.5 weeks, the optima yellow top lost charge. Upon jumping the truck w/ the wife's Tahoe, my AC started to stop working correctly. I'm not sure if the AC was the first indication that my HPM electric fans were about to go. My AC would randomly blow HOT air out of the driver side and that side ONLY. I figured out that if I turn my truck OFF and then back ON the AC would correct itself. A few days later, my wife was T-Boned and the accident totaled her ride. To top the bad luck off, while I was out of town working and my SSS' E-Fans decided to stop working. I live in Houston and need a good reputable performance shop to take my truck to. My fans aren't completely seized because I can spin them with a screw driver and they don't smell burnt up. I let my truck run, but my fans never run as they would usually run once the truck hits 160... I have them wired into the main harness and don't have a bypass switch. I've had them installed for 4yrs and bought them new. Any help is GREATLY Appreciated!
  2. So I bought OEM electric fans from a buddy of mine he said they came of a wrecked 2005 silverado 1500. In the picture whoever had them before him made there own ground with a thick wire on the fuse box. I'm hoping that's fine. My question is the plug with the blue and green wire. Where exactly does this go in my 2003 silverado ss. I know that I have to put blue in pin 42 but the green I have no idea where it would go??? So if anyone's done this install with OEM E-fans please give me answers on how to install without buying a harness would rather try to keep it as if it was straight out of factory. Thanks guys
×
×
  • Create New...