Jump to content

Search the Community

Showing results for tags '4l65e'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Lifestyle & Hobbies
    • Off-Topic/General
    • The Automotive Industry
    • Member Introductions
    • Video & Photography
    • Firearms & Hunting
    • Sports & The Outdoors
    • MiSSed Connections & SSpotted
    • My New Truck
    • Events, Gatherings, & Rallys
    • Comment Box
  • Truck of the Month
    • Truck of the Month
  • Technical
    • General SS
    • How To
    • Builds
    • AWD, Differential, & Transmission Tech
    • Suspension & Brakes
    • Radio/Electronics/Security
    • For Sale/ Wanted
    • Rims and Rubber
  • Engine Technical
    • Engine Tech And Modification
    • PCM Tuning
    • Bolt On Performance
    • Forced Induction and Nitrous
  • Non Silverado SS
    • VHO/V-Max General
  • Street & Strip
    • Street
    • Strip
    • Appearance, Cleaning, & Detailing
  • Preferred Vendors
    • Vendor/Member Praise/Complaints
    • GMPartsDirect.com
    • Black Bear Performance

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Name


Location


Interests


Build Date/TPW


Delivering Dealership


Delivery Date


Modifications

Found 5 results

  1. I am having trouble with my transmission not shifting into 4th gear when ambient temp is below 45F. I am aware that this does happen to a lot of people when it's cold out, and after the trans warms up, it will shift normal to 4th. But my trans will not shift into 4th ever when it's cold unless I drive it to normal operating temp, then park it, shut off engine, pull the keys, open the door, close the door, and then restart my truck. I am guessing this has something to do with the TCC, but am not sure. Both shift solenoids, filter, and fluid are new as of this year. Any help will be greatly appreciated. P.S. I am running a Vigalanti 3200 Stall Torque Converter. But this is the only modification to the drivetrain.
  2. Today my 03' SS started to shift very heavy. From 1-2 it would rev pass 3k. The shift time was very high pass 5sec which is not suppose to do. 2-3 is fine and 3-4 is good also. But than coming to a stop she will stay in 4th gear and not drop down to first. If I manually down shift she will give me first than I shift to second and she's good and so on but that's manually shifting her and she shifts perfect. So the transmission could have not gone out. I do not race in her I don't just randomly dog her around everywhere. I don't even daily her. Was just a good day to drive her and started acting up. I've seen millions of forums and googles and searched everywhere and get different answers which is a headache. ***I hear that my transmission needs a rebuild...than I hear it's a wiring problem....than they say it's a PCM problem...if not that it could be a speed sensor. All that is done to her is a Torquer v2 cam Circle D 3600 converter 243 heads with .660 lift springs Tbss Intake manifold/ tbss throttle body 1 7/8 long tube pace setter headers Volant CAI If anyone could give me any info that would be a big help. Thanks
  3. I purchased my 03 SS in January of 15' and it has always shifted a little slow, it hasn't gotten much worse since I flushed it and added lucas tranny stop slip to it. But the 2nd to 3rd shift is still not very healthy. I'm wondering if anyone has rebuilt these transmissions? I thought about maybe putting a very mild shift kit in as well when I have it all apart. I need suggestions on what rebuild kit to purchase, and any advice to which shift kit to install, or if thats a bad idea. I do body work for a living, but I have a very skilled mechanic friend who will be helping who has rebuilt a few transmissions before.
  4. I searched and read and searched and read. There is so much info on here about transmissions and I'm on info overload. I have a 03 SS it has a whipple 2300 on it, headers, no cats, 42#? injectors, and a speedy in-line fuel pump. The blower is only running factory boost and I don't beat on it (much). I lost my 2/4 band of course, as usual. The guy before me said the transmission was built but did not give any specs on it at all. I will pull it and my Father in-law will rebuild it, he is a mastertech at GM. I want to know what kit I should run and if I should do a stall etc and where I should get said kit... Thanks!
  5. Looking to buy stock or close to stock AWD 4L65E transmission. Let me know what you have. Thanks.
×
×
  • Create New...