Jump to content

SmalltownSS

Member
  • Content Count

    34
  • Joined

  • Last visited

Community Reputation

0 Neutral

About SmalltownSS

  • Rank
    SS Member
  • Birthday 05/03/1989

Contact Methods

Previous Fields

  • Owns
    SS
  • Silverado SS/VHO/TrailBlazerSS Color
    Victory Red
  • SS/VHO/TrailBlazerSS Year
    2003
  • Drivetrain Config
    AWD
  • Delivering Dealership
    Dryden GM
  • Delivery Date
    october 2009
  • Modifications
    Pacesetter Headers, high flow cats, magnaflow mufflers, K+N intake... lots more to come

Profile Information

  • Gender
    Male
  • Location
    Dryden, Ontario
  • Interests
    Trucks, fourwheeling, motocross, sledding, and just about everything else than involves burning gas.
  1. I had my mechanic install my built transmission for me, and they lost one of the front u joint needle bearing and decided to just omit the driveshaft for the test drive. They brought it up o highway speed and made sure it shifted trough all the gears. Would this be enough to smoke the viscous coupling in the transfer case? I have done a load of reading about pulling the shaft for burn outs and 2x4 dynos.... And they all say it's catastrophic. Has anyone been through this? What symptoms should a guy look for?
  2. What about reliability? Do they generally last a long time or do they explode like the G80 that comes stock in these trucks? Has anyone used one in the snow and ice? Will they turn both tires even if it is really slippery?
  3. I put a 160 stat in my truck this summer and was worried that my heater would not blow hot enough.... I wasn't able to find a solid answer online so I decided to leave it in to see if it would work. We have had 3-4 weeks of -30 to -38C (-22 to -36F) and the heater worked fine, just kept it cranked up, was comfortable in a t-shirt cruising Down the highway! Hopefully this information will be useful to somebody in the northern states or Canada thinking about doing a stat.
  4. The G80 finically have up and It didn't take long to get sick of having only 1 rear tire spinning.... Up here we get 5+ months of winter and do alot of drifting, anyone have any experience with a tru-Trac playing in the snow/reliability? Any other ideas or thoughts?
  5. I was just wondering if anyone knew what temperature the 4l65 should be run at to avoid damage or premature wear. Just got back from a road trip, pulling the new 18ft enclosed trailer 5000lbs average temp was 185-190 199 on long hills. This is from the factory temp sender, I have an edge insight cts hooked up to my obd-2 port that shows transmission temp.
  6. My SS is still at the transmission shop, they still aren't sure what is causing the input shafts to break, there has been some progress though. A sonnax super hold billet 2nd gear servo was used instead of the common "vette servo" From what I have been told by another builder is that the super hold servo is alot more aggressive than the vette servo and that could be what is breaking the shafts while shifting into 3rd gear. Lots of guys run the super hold, but generally with high stall converters, and or high horsepower with billet input and output shafts/ drums. The shop has used super hold 2nd gear servos in builds for 2 wheel drive trucks before and have not had any problems but they say "it just chirps the tires when shifting" has anyone else run a super hold 2nd gear servo w/stock input shaft and stock converter with all wheel drive?
  7. Custom tune by zippy, but tuned to be a reliable daily driver, no change to shift pressures or force motor amperage, only changed shift points to match sonnax shift improver Kit. I don't thin it is the tune, the tranission shop was blaming the tune originally but has not mentioned it since they took the truck for a test drive.
  8. They took it apart and it broke the input drum where it connects to the collar and input shaft, which is a very thick piece of metal. Probably because it had a reinforced collar this time, something else had to break! They had the test gauges on it driving down the road and all of a sudden the line pressure went to 200psi and stayed there, it also flipped a "ratio code"? They cleared the code and it has been on 3 test drives since with no high pressure or codes. Anyone heard of this, or have any thoughts?
  9. It looks like the spline where the input shaft slides in is broke on the drum side. Here is a picture
  10. Is it a common failure with N/A stock motors? How come it never broke in 121,000 miles with the stock transmission? I agree the shops transmission horsepower ratings are probably bogus! I think its strange that a truck that makes 300-315 rwhp (if its lucky) would be able to break an input shaft unless there was an internal problem in the tranny.
  11. I have been having a hell of a time with my rebuilt trans. The stock transmission was slipping at 121,000 miles so i sent it to a local performance shop in Manitoba to be rebuilt before it got worse. They did a performance rebuild with what appeared to be all the right parts (alto red band, kolene clutch plates etc) and said it would be good to 550 RWHP which would be more than good enough for my worn out stock silverado motor with headers, custom tune and a cat back. I put 165 miles on the truck and heard a bang when it downshifted from 4th to 3rd during a pass on the highway...... no power to any of the gears. Got the transmission sent in again to be fixed on warranty, it was the input shaft that broke apparently (i have the shaft and drum they sent it to me, it busted the collar where the splined shaft is inserted . I was just driving it around again yesterday and it made it to 70 miles when yet again, passing a mini van at 45 mph it downshifted to 3rd from 4th and went "bang" no power in any gear and making the same "zinging" noise as the first time, so im going to guess its another broken input shaft!! Has anyone else had trouble with this with a N/A stock motor and a 4l60? what is causing this problem? It must be something wrong and I cant afford to have this truck off the road for this much time!! Any advice would be good. Thanks
  12. I just put the newly tuned PCM back in the truck, I have installed factory E-fans and a built transmission as well. I fired the truck up and it seems to run good, but all the interior lights and headlights are flickering seems to go with the RPM of the motor (and this is with the fans off and no other electrical really running). I have done a bit of reading about this, apparently it could be caused by the alternator or the voltage regulator. That being said is there anything anyone can think of that I could have screwed up in the fan install or with the pcm that would cause this instead? It seems kind of odd that this could just be a coincidence that the alternator decided to fail at this exact time. Stock headlights stock stereo
  13. There used to be a how to on here or at least some information about how to install the stock fans out of a 05+ silverado using the stockharness robbed from the donor truck, i cant seem to find it does anyone have it or know where to find it, i am currently getting ready to install the fans and have entire stock wiring harness from the donor and need to take it apart and keep the right wires to pin it into the main plug on my SS thanks
  14. Seems that everyone on here goes with the tru cool max 40k, is that necessary for these transmissions or would one of the smaller ones work (30k or 24k). Also with the large surface area wouldn't the tru cool block the airflow to the condenser and radiator has anyone mounted one behind the air scoop in the front bumper? Also when installed have you guys kept the fluid running through the transmission cooler portion of the radiator or used it as a stand alone cooler. (no transmission failure with debris to worry about int rad cooler) I was thinking if it doesn't increase the line pressure too much it would be great to have it in the radiator to bring the temps closer to operating in the winter. Thanks!
  15. Sounds like there prices are pretty close to bang on if it was 2500 installed in florida! (stuff seems to be a little more expensive up here) Ill call the guys at ptcinc and see what they can do for me. Thanks for the warning on the install, I have talked it over with the transmission builder, I have a registered mechanic buddy helping me so it will all be done properly and will not void my warranty. Should be ready to get this done in the next couple weeks, then its a long slippery slope from there...... built tranny...... hmmm why not a Radix!
×
×
  • Create New...