Jump to content

stirling84

Member
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral

About stirling84

  • Rank
    SS Newbie

Previous Fields

  • Owns
    SS
  • Silverado SS/VHO/TrailBlazerSS Color
    Black
  • SS/VHO/TrailBlazerSS Year
    2006
  • Drivetrain Config
    2WD
  • Build Date/TPW
    9-30-07
  • Delivering Dealership
    integrity
  • Delivery Date
    9-30-07
  • Modifications
    pioneer double din dvd navigation, 2 12" subs, stealth box, 800 watt amp

Recent Profile Visitors

380 profile views
  1. Can you text me 323 5287015

     

  2. It's a direct bolt on. I wanna say it is California legal, but I'm not positive.
  3. Honestly I can't remember, pulled it off before I sold my 06 SS like 8 years ago and it's been sitting in my garage ever since. I think maybe 20k miles or so.
  4. Would prefer to do local pickup only and avoid the hassle of boxing it up.
  5. Used corsa touring cat back exhaust for sale. $150 obo, located in Las Vegas.
  6. The other day I was driving down the freeway and all of a sudden I hear the chime go off in my truck and it says I have low oil pressure. It still seemed to be running just fine though. I checked the oil to make sure it wasn't low. I just changed the oil about a month ago...I always use royal purple and K&N filters. I've driven it carefully a couple times since and I don't hear any knocking or other weird sounds at all coming from the engine but it keeps giving me the warning. When I first turn on my truck the oil pressure shoots up to 80 psi on the gauge and when I start driving, it slowly goes down to 0 psi. Sometimes the gauge just goes kind of wild going up and down really quickly, usually when stopped at a light or while driving slowly this happens. Not sure if my pump is bad or if it could be a bad sensor or something. Any suggestions??
  7. stirling84

    my ss

    my truck
×
×
  • Create New...